0

I'm hosting two twitter bots on Heroku which have been running just fine for multiple months without any need for me to do anything after setting them up. I would push updates automatically via github from time to time which also worked just fine.

I pushed my last update for one of my bots on May 27th. On June 13th both bots just stopped running all of a sudden without me making any changes.

If I run them locally on my machine everything is working absolutely fine, so the problem most likely lies with Heroku. On Heroku it doesn't show any errors and making a fresh deploy also didn't fix it.

Have any of you experienced something like this before and have some advice ? Really not sure how to troubleshoot this and since I'm on the free plan I can't contact support either.

  • 1
    Can you further expand on the “not working” part? Any debugging, errors? – glls Jun 17 '19 at 1:11
  • Thanks for offering help. Just hooked into the heroku logs through the console and it says 'Idling because quota is exhausted'. I find it strange that this isn't shown anywhere in the dashboard. Sorry for taking your time. – Stephen Jun 17 '19 at 1:33
  • no worries, glad you were able to resolve - or at least find out the root cause =) – glls Jun 17 '19 at 2:01
1

Turns out my I just exhausted my quota. Found this out by hooking into the logs from the terminal. I find it quite strange that this isn't shown in the Heroku dashboard and found it quite unlikely since this hasn't happened before and the quota should reset each month.

If you run into the same issue make sure to also check this even if it seems unlikely. Sorry for taking your time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.