3

I had a number of LWC pages (both app and record pages) that were working fine until our upgrade this weekend. This morning, we can't open none of our RECORD pages only.

I tried creating a completely new record page and it fails with the same error.

The org is developing a managed package, so everything has a namespace.

The UI fails to get info about the flexipage:

POST /aura?r=4&aura.DynamicComponent.getTemplateDescriptorWithExpansion=1 HTTP/1.1
Host: myinstance.lightning.force.com
Connection: keep-alive
Content-Length: 1507
Pragma: no-cache
Cache-Control: no-cache
Origin: https://myinstance.lightning.force.com
X-SFDC-Request-Id: <Some id here>
User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
Accept: */*
Referer: https://myinstance.lightning.force.com/lightning/r/my_prefix__My_Object__c/a0FFF0000FFFEFFFFF/view
Accept-Encoding: gzip, deflate, br
Accept-Language: en-GB,en-US;q=0.9,en;q=0.8
Cookie: <Session info here>

message%3D%7B%22actions%22%3A%5B%7B%22id%22%3A%22394%3Ba%22%2C%22descriptor%22%3A%22aura%3A%2F%2FDynamicComponentController%2FACTION%24getTemplateDescriptorWithExpansion%22%2C%22callingDescriptor%22%3A%22UNKNOWN%22%2C%22params%22%3A%7B%22type%22%3A%22Flexipage%22%2C%22attributes%22%3A%7B%22pageDeveloperName%22%3A%22my_prefix__Myg_Page2%22%2C%22objectApiName%22%3A%22my_prefix__My_Object__c%22%2C%22recordId%22%3A%22a0FFF0000FFFEFFFFF%22%7D%7D%7D%5D%7D%26aura.context%3D%7B%22mode%22%3A%22PRODDEBUG%22%2C%22fwuid%22%3A%22SOMEIDHERE%22%2C%22app%22%3A%22one%3Aone%22%2C%22loaded%22%3A%7B%22APPLICATION%40markup%3A%2F%2Fone%3Aone%22%3A%22TAG%20HERE%22%7D%2C%22dn%22%3A%5B%5D%2C%22globals%22%3A%7B%22density%22%3A%22VIEW_ONE%22%2C%22appContextId%22%3A%22SOME%20ID%22%7D%2C%22uad%22%3Atrue%7D%26aura.pageURI%3D%2Flightning%2Fr%2Fmy_prefix__My_Object__c%2Fa0FFF0000FFFEFFFFFAV%2Fview%26aura.token%3DtokenHERE

And the actions part of the response comes back as:

"actions":[
    {
      "id":"394;a",
      "state":"ERROR",
      "returnValue":null,
      "error":[
        {
          "message":"An internal server error has occurred\nError ID: 947460758-10373 (-1122514613)"
        }
      ]
    }
  ]

With error id being different for different users.

Update

Working with SF support I was able to isolate this issue, although there is no solution :(

It seems to only affect orgs that are developing managed packages. What happens is if you have one custom component import another custom component, the js can't compile as it can't find the module (for whatever reason now?)

To replicate this, do the following in Summer 19:

1) Create the first component (e.g. here called TestCo)

Html

<template>
Hello world!
</template>

Js

import { LightningElement } from 'lwc';

export default class TestCo extends LightningElement {}

Metadata

<?xml version="1.0" encoding="UTF-8"?>
<LightningComponentBundle xmlns="http://soap.sforce.com/2006/04/metadata" fqn="testCo">
<apiVersion>45.0</apiVersion>
<isExposed>false</isExposed>
</LightningComponentBundle>

2) Create the second component (here called DummyEditor)

Html

<template>
<c-test-co></c-test-co>
</template>

Js

import { LightningElement, api, wire, track } from "lwc";
import { TestCo } from 'c/testCo'; // note: this doesn't make any difference

export default class DummyEditor extends LightningElement { }

Metadata

<?xml version="1.0" encoding="UTF-8"?>
<LightningComponentBundle xmlns="http://soap.sforce.com/2006/04/metadata" fqn="dummyEditor">
<apiVersion>45.0</apiVersion>
<isExposed>true</isExposed>
<masterLabel>DUMMY</masterLabel>
<targets>
<target>lightning__RecordPage</target>
</targets>
</LightningComponentBundle>

3) Now add the second component anywhere to a LWC record page

4) Try to open the record (note: it WILL work in App Builder, but not in the console)

Update 2

Trying to repro this in a brand new dev org I first added this component to Account object - THAT worked. However, when i created a Custom object, and added the component to that - it fails the same way.

Update 3

As per an answer i got on SF Dev forums, there is a workaround - rename the TestCo component to be Testco, so the tag is c-testco. https://success.salesforce.com/answers?id=9063A000000laNKQAY

This is annoying but maybe a way forward while SF are fixing things

  • Thanks for the write-up. Having the same issue on all scratch orgs since at least yesterday. Interestingly our components work fine in the app builder too. – Adam Squires Jun 17 '19 at 8:27
  • I have the same issue. My scratch Org seems to have been upgraded to Summer 19 over the weekend. However, I have discovered a workaround (well it works for me). I have a LightningOut/VisualForce page with my components on and it doesn't seem to exhibit the problem. If I open the VisualForce page my components get compiled and I can then use the record page. – Jon Jun 18 '19 at 8:56
  • @Jon that's a good workaround. Sadly, we don't have anything in VisualForce, we're a brand new dev org working on an ISV package, so it was all a clean-slate LWC, not even Aura. – zaitsman Jun 18 '19 at 8:58
0

This was a confirmed bug which has been resolved by 1st July 2019 with the rollout of one of the Summer 19 patches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.