1

We have LWC's created in our managed package. They are marked as exposed. Whenever we try to include one in a record / flexi page in a Subscriber's org we are getting an internal server error with an Id.

There are no debug logs being saved and it does not matter what LWC it is.

Every LWC I've tested works in our scratch orgs.

Please advise on how to find out what is causing this issue. Do I need to log a case with Salesforce since it appears it may be on their end?

  • 1
    I would raise via Partner Portal - with GACKS, they should be able to give you the details - it is often something quite simple to fix, but without knowing the details, you are just guessing right now – BritishBoyinDC Jun 14 '19 at 12:41
  • I also just saw someone posted something very similar in the DX Success Group so wondering if there is a wider issue here? – BritishBoyinDC Jun 14 '19 at 12:46
  • 1
    I solved this issue with an Aura Component to host the LWC's. Just had to pass in the recordId and it worked great. Advice: Create one LWC Container component and in the .design file add a picklist with available LWC's to dynamically render which component you choose. – Tyler Kauffman Jun 15 '19 at 15:14
1

There is a knows issue for LWCs in packages with capital letters in the namespace: https://success.salesforce.com/issues_view?id=a1p3A000001SHvtQAG

The workaround is exactly what Tyler described - wrapping in an Aura component.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.