4

Generally, the question stands as what steps need to be done in order to send 2-nd generation managed package for security review.

Current conditions:

I have developed 2-nd generation managed package on standalone dev org.

After that client has created their partner salesforce account and linked both namespace and developer dev orgs to that partner account.

here on "Publishing" tab showing, that there are no packages on that orgs.enter image description here

Am I missing something? Is it possible to publish 2-nd generation managed package for security review? If no, what do I need to do in order to send it to security review ?

Update. Winter '20 made Second Generation Managed Packages GA. Go ahead and publish them!

4

As this mechanism is still beta (I added the bolding here):

As a beta feature, Second-Generation Managed Packages is a preview and isn’t part of the “Services” under your master subscription agreement with Salesforce. Use this feature at your sole discretion, and make your purchase decisions only on the basis of generally available products and features. Salesforce doesn’t guarantee general availability of this feature within any particular time frame or at all, and we can discontinue it at any time. This feature is for evaluation purposes only, not for production use. It’s offered as is and isn’t supported, and Salesforce has no liability for any harm or damage arising out of or in connection with it. All restrictions, Salesforce reservation of rights, obligations concerning the Services, and terms for related Non-Salesforce Applications and Content apply equally to your use of this feature. You can provide feedback and suggestions for second-generation managed packages in the Packaging 2 Beta group in the Trailblazer Community.

my guess is that the Security Review process does not yet support it.

  • so I need to create brand new dev org, push metadata to that org, create 1-st generation package, link this org to partner org and then send to security review, am I correct? – Oleksandr Berehovskyi Jun 13 at 12:17
  • 3
    @OleksandrBerehovskyi Yes. But you will need the 1st generation package to go live per the above statement anyway. At least the sfdx tools are quite good now for converting formats. A colleague expressed the opinion that 2nd generation will be GA around the end of the year, but don't know what that opinion is based on. – Keith C Jun 13 at 12:20
  • 3
    @OleksandrBerehovskyi P.S. you can still install the 2GP in to the dev org that contains the managed 1GP instead of moving metadata "manually," so the new feature isn't completely useless. – sfdcfox Jun 13 at 13:33
  • 1
    Also, if you aren't already using it, the ISV Falcon Template makes DX work much better with 1GP: github.com/sfdx-isv/sfdx-falcon-template – BritishBoyinDC Jun 13 at 14:21
2

The future is here - the Winter '20 release will make Second Generation Managed Packages (2GP) publically available and you'll be able to submit for security reviews / publish on the AppExchange.

0

Second generation packages can not be listed on AppExchange as of yet. They are not even GA. Please use first generation packages to publish on AppExchange.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.