1

I am trying to use the force:org:clone command(which is in BETA) but my SFDX tells me it doesn't exist.

https://developer.salesforce.com/docs/atlas.en-us.sfdx_cli_reference.meta/sfdx_cli_reference/cli_reference_force_org.htm

This release contains a beta version of the org:clone command, which means it’s a high-quality feature with known limitations. The the org:clone command isn’t generally available unless or until Salesforce announces its general availability in documentation or in press releases or public statements. We can’t guarantee general availability within any particular time frame or at all. Make your purchase decisions only on the basis of generally available products and features. You can provide feedback and suggestions for the org:clone command in the Salesforce DX group in the Trailblazer Community.

I updated SFDX to the latest version(sfdx update) but it'still giving me the same error.

Is there a specific way to enable beta features for SFDX?

2

You'll need to install the prerelease version:

sfdx plugins:install salesforcedx@pre-release

This will install the newer-than-latest release and let you try out any beta features.

To get back to the current stable version, you can downgrade with:

sfdx plugins:install salesforcedx@latest
7
  • Thank you! I thought there might be some command like that that I was missing. Where did you find out about this command? – Arthlete Jun 12 '19 at 16:16
  • 1
    @Arthlete npmjs.com/package/salesforcedx?activeTab=readme ... and probably other places. I don't remember where I first saw it, but this project explains more. – sfdcfox Jun 12 '19 at 16:18
  • 1
    In a week we should receive the new update where it will be baked into the cli – Mohith Shrivastava Jun 12 '19 at 16:34
  • Their example is incorrect. I tried this sfdx force:org:clone -u me@mysandbox.com.full -a FULL_CLONE -t sandbox but get To indicate which sandbox org you want to clone, specify SourceSandboxName in a definition file or as a command line argument.. I looked at all the arguments that are listed for the command and don't see anything related to SourceSandboxName. Isn't the username making it clear enough which sandbox I am trying to clone? – Arthlete Jun 12 '19 at 19:55
  • 1
    @Arthlete Totally. Tweeted out your question for more visibility. We'll get this sorted. – sfdcfox Jun 12 '19 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.