1

I am having an issue where, using the Metadata API, I can't get my custom app to be the default App after installing the FinServ managed package.

I first am deploying my custom App and setting the application visibility as the following in all of my profiles: <applicationVisibilities> <application>Custom_App</application> <default>true</default> <visible>true</visible> </applicationVisibilities>

Then, when later deploying the FinServ managed package, it sets 'Retail Banking' as the default app for all of my profiles. I try getting around this by re-deploying the above application visibility settings for my profiles, but Retail Banking remains the default app when opening up Salesforce.

Manually changing the opened app when logged in is the current workaround, but this isn't tenable for my automated tests. Is there something I'm missing?

0

Defaults Apps are profile based, I think. Have you tried doing a retrieve Metadata API call where the retrieve items are both the profiles AND the app?

The profile is a weird type of metadata, which when retrieved with the API, only includes details of other types that are included in the same retrieve call. So for example if you just retrieve profiles and 1 custom object, only the FLS for that object are exported.

So perhaps you need to retrieve the app and the profiles in the same retrieve call, and then use the result of that to make your deploy call.

| improve this answer | |
  • I am retrieving both the profiles and all the apps; it shows that my Custom_App is the default app. And yet it's still opening the Retail Banking app on first load-up... – DanTheMan Jun 10 '19 at 20:11
  • 1
    Have you tried with a user that's never logged in? I wonder if it's a user preference – CommonCoreTawan Jun 10 '19 at 20:14
  • I'll try deploying to a new org and retrieving before I log in - I'll post what I find – DanTheMan Jun 10 '19 at 20:19
  • nope, still happening – DanTheMan Jun 13 '19 at 15:11
  • I've tried setting all of the FinServ apps to <default>false</default> in the profiles as well, but that now just sets the standard "Sales" app to the default... it's still not respecting the fact that I'm setting my Custom_App to <default>true</default>, which is really the root issue here – DanTheMan Jun 13 '19 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.