1

In Builder at Community I dragged Language Selector Component to Content Header then I click on Preview. With this action, Language Selector is visible. But when I click on Publish then login with user it is not visible ?

  • With Preview enter image description here

  • With User login enter image description here

Why ?

  • Active on Live Community is checked – Davis Clack Jun 5 at 9:54
2

Language selector isn't visible for normal users. It's only there for Admins (and guest users) to view the page in different languages. Otherwise, the Language automatically is set to that which is set in their User Settings.

Note that I agree this is inconvenient for situations where a User may be multi-lingual, or simply not happy with the translations shown in their language. There is an idea that you can upvote to nudge Salesforce into making this available for all Community Users: Language Selector available when using the community as Partner/Customer user

Here's a screenshot from the User Settings where Users can set their own language: (This came from the default "Customer Account Portal" Theme, other themes might not look the same)

enter image description here

  • 1
    When I set language in User Setting. It isn't available so I want to show Language Selector for User choice language. The user in image is Admin user. – Davis Clack Jun 6 at 1:55
  • 1
    @DavisClack I updated the Answer to show where the language setting shows up – DaveS Jun 6 at 7:39
  • Hi @DaveS. I also changed language in User Setting but it isn't effect. I really don't understand – Davis Clack Jun 6 at 7:50
  • I'm sorry. I really stupid. I changed in the community but I tested on another – Davis Clack Jun 6 at 8:00
  • @DavisClack :-) That's not stupid, that's tired of looking at the same problem. Happens all the time to me. – DaveS Jun 6 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.