0

I'm using SFDX on a Windows machine.

The following command is giving me errors when running from a bash terminal:

sfdx force:source:convert -d mdapi -n 'My Alias'

It keeps returning this error:

'D:\Program' is not recognized as an internal or external command, 
 operable program or batch file.

I've tried using double quotes as well, but the result is the same.

3
  • can you run simple sfdx command and check whether your command prompt is recognizing it or not? – sanket kumar May 29 '19 at 17:51
  • 2
    Seems like that's a classic whitespace path issue. – Oleh Berehovskyi May 29 '19 at 18:28
  • Using the sfdx CLI in bash on Windows, whether through WSL or other means, is not recommended/supported. – Thomas Taylor May 29 '19 at 18:33
-1

Enclose the path in single or double quotes

sfdx force:source:deploy -x "C:\Users\tania.sen\OneDrive - SourceGitREP\GIT_SFDX\manifest\CustomMetadata_Object.xml" -l RunSpecifiedTests -r RecurringBillin_Test --loglevel fatal -c

1
  • 2
    OP mentions that they have tried both single and double quotes. – Derek F Aug 17 '20 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.