0

I was trying to create a new apex class, however to my surprise I did not find the "New" button that is supposed to be next to the "Generate from WSDL" does anyone know why this may be happening?

This is "Salesforce Enterprise edition" on a sandbox account.

Is there a specific option that I am supposed to enable in order for the "New" class button to appear? Screenshot

  • 1
    Are you using a System Admin profile? If not, do you have Author Apex permission enabled on that profile? – Jayant Das May 22 at 18:25
  • @JayantDas I am not quite certain I am very new to salesforce, actually a client of mine asked me to do some work which involves connecting his salesforce objects to the webapp I was developing for him. So he provided the account details. Is there a way to see the permissions enabled for this profile? – Yuran Pereira May 22 at 19:18
1

Login to Salesforce > Setup > In Quick Find box to the left type User >Click on the item called Users > click on the name of the user you have logged in as > Under the section User Detail, look for the label called Profile. Click on the profile name (This will take you to the profile setup page ) In the section System, click on System Permissions and find the label 'Author Apex'

If you have this Check box flagged as true, you should be able to create New Apex class. If not flagged as true, then hover over the little icon 'i' and it will tell you what permissions you need to have the 'Author Apex ' checkbox enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.