0

We have recently adopted person account and are trying to move chatter feed from contacts to person accounts.

According to this article: https://help.salesforce.com/articleView?id=000213215&type=1 , we need to insert chatter feed in this case. However, feedItem with type 'TrackedChange' cannot be inserted via dataloader.

The type of FeedItem. Except for ContentPost, LinkPost, and TextPost, don’t create FeedItem types directly from the API.

So what is the normal way of handling this issue?

As requested, I post my sample anonymous block code in here:

FeedItem fi = new FeedItem();
fi.ParentId = '0016D00000AEjiRQAT';
fi.Type = 'TrackedChange';
fi.isRichText = false;

insert fi;

It still result in the same error message.

  • I’d suggest execute anonymous or a batch class designed for it? (That you would delete after using) – Sebastian Kessel May 21 at 4:38
  • @SebastianKessel Thanks for the suggestion. Actually I tried execute anonymous but doesn't seem to work very well as well. Got the same error message. Do you want me to post the sample apex code? – Lance Shi May 21 at 4:43
  • Code could make it easier to get help. Make sure you ExecAnon from the Dev Console. If not, try with an apex class in a sandbox. Exec Anon in an IDE could be using an API to execute. – Sebastian Kessel May 21 at 4:47
  • @SebastianKessel I executed in developer console, which I believe is also using API to execute as well. Regardless, I got the same error. Code posted as requested. – Lance Shi May 21 at 4:56
  • You should save this inside of a class and try. That won’t use an API – Sebastian Kessel May 21 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.