0

I'm trying to update a Contact record as Guest Community User. Lightning:recordEditForm seems does not allow community guest user to load or save the record, and gives me following error on community page.

enter image description here

Javascript Errors:

action: null ​ component: "lightning:recordEditForm" ​ componentStack: "[lightning:recordEditForm]" ​ data: null ​ handled: false ​ id: -1549398249 ​ message: "Error in fetching record or record metadata. [[object Object]]" ​ mf: "wireRecordUi/a._subscription<.error<()@https://dev-cuc.cs6.force.com/components/lightning/recordEditForm.js:5:420\nerror()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:25275\n_errorWithErrorHandling()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:25911\nemitError/<()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:27446\nemitError()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:27386\n_wireTransformedObservableWithOperation/a<()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:29358\nerror()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:25275\n_errorWithErrorHandling()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:25911\nemitError/<()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:27446\nemitError()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:27386\n_wireTransformedObservableWithOperation/a<()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:29358\nerror()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:25275\n_errorWithErrorHandling()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:25911\nemitError/<()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:27446\nemitError()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:27386\n_handleValueProviderError()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:48149\nget/<()@https://dev-cuc.cs6.force.com/components/force/lds.js:2:44628" ​ name: "AuraFriendlyError"

enter image description here

I tried to save the record using a WITHOUT SHARING CLASS and forcing the Contact record Id, which is working fine, but it doesn't load the values to fill the form. Any thoughts, suggestions to workaround this properly, much appreciated. Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.