4

We've developed a lightning component which hosts a react app within a container. I've noticed that sometimes after pushing a change to it in a scratch org (i.e. updating the static resource which the component's container references) via "sfdx force:source:push", refreshing the lightning page fails to render the component. The JS console logs the error:

index.html:1 Failed to load resource: the server responded with a status of 403 (Forbidden)

In such situations, the component usually loads ok in a different browser e.g. Safari vs Chrome. After some time's elapsed, it starts working again in the original browser.

Most worryingly, we've seen this issue affect a customer who installed our managed package containing this component. They component worked, then later failed to load (403), and then worked again after some period of time.

Has anyone seen similar issues?

Looking at the URL to load index.html, I can see the hostname is specific to the lightning component container. The container's static resources are in a zip archive.

We've also seen issues with the component/container's associated cname record not being created by Salesforce after a managed package (with the component in it) was uninstalled & reinstalled, which SF support helped us resolve. In this case the hostname wasn't resolving, so I think the 403 error is a separate issue.

2
  • I'm getting this same issue. Even with Salesforce's own sample code. – Jason Allshorn May 20 '19 at 4:29
  • Were you able to resolve this issue? We are experiencing the same issue. – aheuermann Jan 12 '20 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.