0

I have one permission set and one conncted app ,I have enabled this Connected app in permission set ,but when i am retiriving Permissions set not able to retrieve it in Package.

i am doing like below.

<types>
    <members>TestPermission</members>
    <name>PermissionSet</name>
</types>
<types>
    <members>*</members>
    <name>ConnectedApp</name>
</types>

but still permission is not coming to permission set metadata in permission set enter image description here

  • It is not clear what are you trying to accomplish? Are you trying to move the permission of connected app with permission set?? OR are you moving the connected app itself? – Mr.Frodo May 9 at 9:51
  • Yes I am trying to move permission of connected app with permission set – sudhanshu May 9 at 10:36
  • Your XML looks right. Something else is going wrong. The connected app does not have to be mentioned in the Permission Set or anything like that, either. This should work. – Bill Appleton May 9 at 19:46
  • No But if i want associate a connetced app to permission set and need to deploy this metadata to other org.then how can i do it. – sudhanshu May 10 at 4:45
  • Suppose In other org i have already connetcd app present and just want to enabled it while deploying permission set then how can i do it – sudhanshu May 10 at 4:46
1

SetupEntityAccess is the junction object between Permission Sets and Connected Apps. SetupEntityAccess is a standard object, not metadata, and it does not appear in the Permission Set metadata. Hope that helps.

https://developer.salesforce.com/docs/atlas.en-us.218.0.object_reference.meta/object_reference/sforce_api_objects_setupentityaccess.htm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.