2

I was able to create a project in VS code. Also able to authenticate the org. In the package.xml when i right click & click on "SFDX : Retrieve source in Manifest from Org" - i'm getting the following error message :-

UNC paths are not supported. Defaulting to Windows directory. ERROR running force:source:retrieve: This command is required to run from within an SFDX project.

It ended with exit code 1.

Any pointers to resolve this will be really helpful.

TIA.

enter image description here

8
  • are you running the command in the appropriate path? maybe you can share a screenshot of your directory and project, same for the context of where you are running the command?
    – glls
    Commented May 8, 2019 at 18:16
  • I din't run the command. I right clicked in the package.xml file & clicked on the option to retrieve from Manifest.
    – Sunil
    Commented May 8, 2019 at 18:18
  • if you run it using the command line it works normally then?
    – glls
    Commented May 8, 2019 at 18:19
  • Added screen shot for better clarity on this issue.
    – Sunil
    Commented May 8, 2019 at 18:21
  • Never tried running this in Command line.
    – Sunil
    Commented May 8, 2019 at 18:26

2 Answers 2

5

Paths starting with \\ (UNC) are not supported. You would need to map the drive to a local drive letter in order to use the network drive effectively. The latter error ("this command is required to run...") is simply a symptom of the first error.

1
  • The one thing I'd add is that you'll need to reopen your project from the mapped drive once you've done this.
    – Wes Nolte
    Commented May 12, 2022 at 10:39
0

I have faced same issue, I was creating project with SFDX:Create Project with manifest with default path.

I manually selected local C drive folder and SFDX commands started working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .