4

I installed the sf extension for vscode and got everything to run with the default package.xml. I exported the whole package from my org with the help of Package builder and inserted it to the package.xml in the manifest folder. Now retrieve source from org exits with this error:

> Starting SFDX: Retrieve Source from Org
> 
> 15:10:34.965 sfdx force:source:retrieve --manifest
> p:\sf_code\developer\manifest\package.xml ERROR running
> force:source:retrieve:  EISDIR: illegal operation on a directory, read
> 15:12:45.841 sfdx force:source:retrieve --manifest
> p:\sf_code\developer\manifest\package.xml ended with exit code 1

I get the same error when entering the command to the sfcli outside vscode

  • Do you have a default org setup? Otherwise you might need to use the -u MyConnectedOrg parameter in the force:source:retrieve command – Brian Miller May 7 '19 at 14:02
  • Yes I am connected to my sandbox and I retrieved some data but not everything – q-jack May 7 '19 at 14:17
  • 1
    Probably, it's possible to run it only from the project folder. sfdx:source:retrieve --manifest ./manifest/package.xml – ytiq May 7 '19 at 14:56
  • What do you mean? Am I not running it from the project folder? >sfdx force:source:retrieve --manifest p:\sf_code\developer\manifest\package.xml – q-jack May 8 '19 at 6:30
  • I also navigated to the project folder and sfdx force:source:retrieve --manifest manifest\package.xml. Got the same error – q-jack May 8 '19 at 7:02
1

There is an issue discussed here - https://github.com/forcedotcom/salesforcedx-vscode/issues/680

Retrieving any metadata with a folder structure seems to have this problem. Remove them from package.xml and things should work fine.

Use ANT to retrieve the hierarchical metadata and add it to the project folder.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.