1

I've create a SFDX Plugin with sfdx plugins:generate. When the plugin is linked using sfdx plugins:link . the command hello:org is available and work properly. When this same plugin is deployed to npmjs and installed using sfdx plugins:install the command hello:org is not even available.

Does anybody knows the reason why?

screenshot when using the plugin from local directory: enter image description here

screenshot when using the plugin from npmjs: enter image description here Note the command hello:org is not even available after install.

Evidence of plugin installed: enter image description here

The source code: https://github.com/forcexp/autocode

The npmjs page: https://www.npmjs.com/package/@forcexp/autocode

  • What command are you running in command line ? Can you screenshot your terminal ? – Mohith Shrivastava May 5 '19 at 18:29
  • @MohithShrivastava I've updated the description with the screenshot. – Saulo May 6 '19 at 17:14
  • when you run sfdx plugins , what do you see ? – Mohith Shrivastava May 6 '19 at 17:20
  • Question edited with the screenshot – Saulo May 6 '19 at 19:13
  • Did you ever figure this out? – jmrjulian Nov 1 '19 at 22:08
0

You need to run 'sfdx plugins:install @salesforce/sfdx-diff' command in terminal and restart VS code. Terminal may prompt you to get confirmation before installing it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.