3

As of today I can no longer login to newly created DE Orgs spun with the Environment Hub. Login works sometimes directly after creation for some minutes or does not work at all.

It just shows an endless spinner loop like this:

enter image description here

Also Orgs are affected, which I have created over the last couple of months. Older Orgs however and Production Orgs of our clients seem to work as expected. But I could only test some of them.

For users which are switched to Classic, login work on ALL Orgs. Only LEX seems to be affected.

Update 2019-05-06:

This is getting worse instead of better. On Friday and today it worked sometimes, but it comes and goes. Now I have also an SDO we need for a demo for prospect affect and therefore inaccessible and unusable. Very very serious problem!

Looking at the console:

enter image description here

enter image description here

Deep insights

Root cause is the unavailability of some resources to load. One of these resources is app.js - this JS file is hosted by Salesforce on different URLs. Sometime it is

https://{!MyDomainName}.lightning.force.com/l/%7B%22mode%22%3A%22PROD%22%2C%22app%22%3A%22one%3Aone%22%2C%22serializationVersion%22%3A%221-0.34.7-b%22%2C%22split%22%3A%22t%22%2C%22loaded%22%3A%7B%22APPLICATION%40markup%3A%2F%2Fone%3Aone%22%3A%22ROs60GCrLD7ilLtHHAjnCA%22%7D%2C%22ls%22%3A1%7D/app.js

Note https://{!MyDomainName}.lightning.force.com with {!MyDomainName} replaced by the MyDomain of the org. If this is happening, ==> it WORKS FINE!

But sometimes Salesforce is using this

https://static.lightning.force.com/na85/l/%7B%22mode%22%3A%22PROD%22%2C%22app%22%3A%22one%3Aone%22%2C%22serializationVersion%22%3A%221-0.34.7-b%22%2C%22split%22%3A%22t%22%2C%22loaded%22%3A%7B%22APPLICATION%40markup%3A%2F%2Fone%3Aone%22%3A%22ROs60GCrLD7ilLtHHAjnCA%22%7D%2C%22ls%22%3A1%7D/app.js

Note that it is now https://static.lightning.force.com - to be even more precise: it is ...static... instead of ...{!MyDomainName}... in the URL.

This static is THE KILLER. If static comes into play, the Lightning Experience is just blocking in the loading screen and the timeouts are happening, and nothing is usable at all.

@Salesforce: PLEASE HELP !!!

even more insights

This is dependent on the internet carrier!!!! When I'm logged in via our LAN (carrier=www.netcomdata.de) static ==> fails. When I loggin via my mobile phones hotspot without changing anything else (carrier=www.telekom.de) static ==> is working fine!!!

So how to disable static.salesforce.com for good?

traceroute via netcom (**FAILURE) is**

>tracert 23.67.136.141

Tracing route to a23-67-136-141.deploy.static.akamaitechnologies.com [23.67.136.141]
over a maximum of 30 hops:

  1     4 ms     1 ms     2 ms  fritz.box [192.168.0.254]
  2     3 ms     1 ms     1 ms  10.0.124.254
  3     5 ms     4 ms     3 ms  gw.sciencepark.netcomnetz.de [80.69.206.225]
  4     5 ms     3 ms     3 ms  gw12.netcomnetz.de [80.69.193.194]
  5     6 ms     7 ms     6 ms  decix-fra9.netarch.akamai.com [80.81.192.28]
  6     6 ms     6 ms     6 ms  a23-67-136-141.deploy.static.akamaitechnologies.com [23.67.136.141]

traceroute via telekom is (**WORKING)**

>tracert 23.67.136.141

Tracing route to a23-67-136-141.deploy.static.akamaitechnologies.com [23.67.136.141]
over a maximum of 30 hops:

  1     2 ms     2 ms     1 ms  192.168.43.1
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6     *        *        *     Request timed out.
  7     *        *        *     Request timed out.
  8     *        *        *     Request timed out.
  9     *        *        *     Request timed out.
 10    91 ms    79 ms    79 ms  80.156.5.147
 11   163 ms   139 ms   166 ms  217.239.51.54
 12    82 ms    82 ms   119 ms  62.157.250.38
 13   128 ms    95 ms    93 ms  akamai-row.franco32.fra.seabone.net [195.22.214.3]
 14    95 ms    90 ms    84 ms  a23-67-136-141.deploy.static.akamaitechnologies.com [23.67.136.141]
  • 1
    now it works again. We where not able to login for hours, so we could not work and wasted a good part of this day unproductive checking if the problem was on our end. But it was not for sure. It was a temporary Salesforce bug. Unfortunately not visible on trust.salesforce.com or anywhere. – Uwe Heim May 3 at 11:29
  • 1
    this is absolutely not stabel. Sometimes it works, sometimes it does not. This issue is wasting a lot of time. – Uwe Heim May 6 at 9:56
  • Having the same issue, even in Production orgs. Either stays at the loading sign, or another one has Quick Actions that are not accessible - which I need in order to test functionality that already was deployed :-/ – Brian Miller May 6 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.