0

I am Trying to update one Field in Account using postman but it's not letting me update it. I also Turned off history tracking for an Account. I have given full access to my app in Salesforce.  eg 

https://test.salesforce.com/services/data/v40.0/sobjects/Account/2236I111ULVqnRLE
data = {
    "Name": "Test Company"
}

I also tried with the query but still, the same issue occurs. how can I figure out what's the problem is?  one more thing it is allowing me to update values for some of the accounts. what more I can check. Please help me with this ​​​​​​​ Postman Request

  • 2
    The error seems to be coming from a standard duplication rule which is turned on at your org? – Raul Apr 30 at 13:16
  • 1
    What does this post have to do with the Salesforce Communities feature? Please try to only apply tags which are relevant to your question. – Adrian Larson Apr 30 at 13:34
-2

this error is probably throwing due to duplicate rules(standard/custom) that has already been there in your org.

To tune this issue, you can try it same thing for contact object.

https://test.salesforce.com/services/data/v40.0/sobjects/Contact/2236I111ULVqnRLE data = { "LastName": "Test Company" }

if it's updated successfully without any error then there is no issue with how you calling the REST API

  • I tried updating one contact and it's been updated. I don't understand whats the problem in updating Accounts – Priya Harkulkar May 13 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.