1

I am facing something that I can't understand.

I try to retrieve all existing emails by using the WS Proxy utils but I always have an empty response.

{"Status":"OK","RequestID":"cc1da13a-cee1-4aa6-a201-e7b0f7578d27","Results":[],"HasMoreRows":false}

It is exactly the same code as described here (I just added a line to show the response) :

https://developer.salesforce.com/docs/atlas.en-us.noversion.mc-programmatic-content.meta/mc-programmatic-content/ssjs_WSProxy_advanced_retrieve.htm

Is someone have an idea?

What's wrong ? I have a lot of email in Content Builder.

  • Are you using a Fuel token for authentication in your Soap calls, or are you using a client id and secret? – Mike Apr 26 at 14:17
  • Have you confirmed your application is configured for use in the business unit where your emails reside? – Adam Spriggs Apr 26 at 18:46
  • 2
    The WSProxy will only pull from Classic Content - you will need to use the REST calls to get the emails from Content Builder (developer.salesforce.com/docs/…) – Gortonington Apr 26 at 19:25
  • To answer to every asked questions (maybe it can help others) : Mike, the call is directly done in a CloudPage (for test purpose). I used the setClientId() method (developer.salesforce.com/docs/…) in order to impersonate access with an account configured as API User. // Adam, as the call is done in a CloudPage (created in the same BU as the emails to retrieve), I can assume that rights and permissions are ok. – Pleb May 6 at 10:30
3

As I believe this may be the solution (OP please let me know if not) I am going to change my comment into an answer to allow it to be found more easily for anyone facing the same issue.

The WSProxy will only pull from Classic Content - you will need to use the REST calls to get the emails from Content Builder (https://developer.salesforce.com/docs/atlas.en-us.noversion.mc-apis.meta/mc-apis/routes.htm).

This is due to the fact that WSProxy is only built to interact with the SOAP API Methods and Objects and not anything in the REST API for SFMC. The REST API is required to gather anything from Content Builder as it is hosted on a separate location from SOAP.

  • Hi guys, First of all, I would like to thank all of you for the help. @Gortonington, you were right ! All emails were created in Content Builder that's why my request returned 0 record. – Pleb May 6 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.