2

I've created a text formula field, but I've been hitting a wall with the CASE portion of the formula: I keep getting the "Error: Syntax error. Missing ')'" message. Here's what I created:

Account.Name & 

 CASE(RecordType.Id, 01260000000UHnk, ' - Customer Support SLA - ', 
                    01260000000Q5Ok, ' - Renewal SLA - ', 
                    ' - Non-Standard SLA - '
     ) & 

TEXT(MONTH(Contract.StartDate))+"/" +TEXT(DAY(Contract.StartDate))+"/" +TEXT(YEAR(Contract.StartDate))

Everything seems to be in order, but I cannot figure out what's missing. Any help here would be greatly appreciated!

  • Have you tried enclosing the record type ids in quotes and see if it works, I think that may be your issue here. – Jayant Das Apr 24 at 18:19
5

The ID values also need to be in quotes. The error is a bit of a red herring; it's just how the parser reports errors.

  • Perfect - this worked! Gotta love a platform that utilizes literary devices in error messages. – Trevor W. Apr 24 at 18:25
1

Your issue seems to be on the values of the Id field and that it needs to be enclosed within quotes as well:

CASE(RecordType.Id, 
    '01260000000UHnk', ' - Customer Support SLA - ', 
    '01260000000Q5Ok', ' - Renewal SLA - ', 
    ' - Non-Standard SLA - '
 )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.