0

I am trying to follow a Trailhead which instructs me to create a SFDX project in VS Code. I've been using VS Code for awhile and all is current. While troubleshooting this issue, I did update my Salesforce CLI extension, but it was already current.

I'm at a loss. Please help!

  • 5
    Please edit your question to give more detail: What's the name/link of the Trailhead module? What is the exact VS Code command you are running from the command palette? Both of the project commands (Create Project and Create Project with Manifest) will prompt you for a project name and then open a window to indicate where the project files should go. Are you seeing those prompts and entering/selecting valid options? – Thomas Taylor Apr 22 at 19:10
1

You may also need to check and re-install the latest version of VS Code even if "Check for updates" says you're on the current version

  • Please mark this as the correct answer if it answered your question. Thanks! – Ayoola Olapo Apr 25 at 15:33
0

I remember facing this issue a while back. There can be two fixes I can think of

  1. Run

    sfdx update

    and update your VSCode extensions. If this fixes your issue it's likely because of SFDX CLI has now moved to OCLIF framework rendering some backward compatibility issues.

  2. Create a blank package.json file in the directory where you're running the project:create command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.