2

I have installed a server-to-server API package in Salesforce Marketing Cloud. Client id, secret, and endpoint URIs for token auth and SOAP are visible.

Using this info I am trying to setup the SFMC connector in Mulesoft flow, but when testing the connection it always fails with error obtaining access token (404 not found). I assume a lot of people here have this connector setup and running fine. Is there anything special that needs to be configured on SFMC-side?

According to documentation the Authentication Base URI stated under access details for the app in SFMC should be appended with /v2/token like this: *auth.marketingcloudapis.com/v2/token. I have tried a couple of variants but no success. What could be incorrect on SFMC-side?

0

The correct format for oAuth 2.0 would be https://{{TSE}}.auth.marketingcloudapis.com/v2/token

Does mulesoft support the new oAuth 2.0 authentication method?

Looking at this url its is unclear

https://docs.mulesoft.com/connectors/salesforce/salesforce-mktg-connector

You can test by creating an legacy installed package (uncheck the enhanced package)

https://developer.salesforce.com/docs/atlas.en-us.mc-app-development.meta/mc-app-development/installed-package-types.htm

and make a call to the v1 endpoint

https://developer.salesforce.com/docs/atlas.en-us.noversion.mc-getting-started.meta/mc-getting-started/get-access-token.htm

  • The v1 endpoint won't be supported after Aug. 1, 2019: help.salesforce.com/… – Jackson Chen Apr 19 at 18:55
  • thanks for the reply, keep getting the same error though, i suspect there is some configuration missing on SFMC-side, does this require some sort of IP whitelisting maybe? i cant find any info on the subject – Sebastian Håkansson Apr 21 at 8:01
  • have you tested the token call in postman? – EazyE Apr 21 at 22:08
  • hi, just an update to this issue, it actually works requesting the token with Postman, so far so good. One thing I learned though was that for this to work the setting for Client Authentication had to be set to -> "Send client credentials in body" it will not work when it is set to "Send as Basic Auth header"..... Maybe this is why it wont work with Mulesoft? digging a little bit deeper into this now – Sebastian Håkansson Apr 26 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.