0

few dacks back we have enabled country & state picklist values.

So, when trying to convert a lead with a country called Canada they are facing an issue. because currently, the default country is the United States.

As per debug logs:

System.DmlException: Insert failed. First exception on row 0; first error: FIELD_INTEGRITY_EXCEPTION, There's a problem with this state, even though it may appear correct. Please select a state from the list of valid states.: Shipping State/Province: [ShippingState]

I have tried a few things:

1.Updated default country to none
2.Updated organization country to none
3.Tried to map fields(State & others) via process builder

But no luck.So, could you please help me on this.

  • Could you check if state/country picklists are enabled? Probably just need to rescan customizatins and data in Setup->Data->State and Country/Territory Picklists – pklochkov Apr 15 '19 at 12:01
  • What's in the State field on that lead record? – David Cheng Apr 16 '19 at 0:29
  • 1
    To both the above comments, please see that the OP wrote: "we have enabled country & state picklist values" so 1. State/country picklists are enabled, and 2. The State field is the Lead State picklist field. – DavidSchach Apr 16 '19 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.