0

When attempting to generate Apex from a 3rd party WSDL, I'm getting below error.

enter image description here

I noticed this has soap12:binding, I tried to change this to soap11. I still get the error message, and fails to generate Apex from WSDL.

I'm new to wsdl2apex, and trying to figure out what could help fix it.

Appreciate any help/thoughts to fix it. Thanks.

  • In what way did you change it to SOAP 1.1? Did you regenerate the whole WSDL in the 1.1 format that the corresponding web service would support? – Daniel Ballinger Apr 15 at 20:32
  • Hi @DanielBallinger thanks for your comment, Got no access to this 3rd party WSDL. Being new to this, I went through previously posted questions, downloaded the wsdl manually tried to replace it, not too sure if I'm on the right track. – Pasan Eeriyagama Apr 15 at 23:16
  • Unfortunately you won't be able to modify a SOAP 1.2 binding into a SOAP 1.1 binding and successfully call it with the automated wsdl2apex tooling. If you have only limited requirements for the service you could try and replicate the requests with a raw HttpRequest. – Daniel Ballinger Apr 16 at 9:37
1

If you have two part with <wsdl:port ..>..</wsdl:port> you can try delete part for soap12: `<wsdl:port name="xxxSoap12" binding="tns:xxSoap12"> <soap12:address location="http://xxx" /> </wsdl:port> ` It works for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.