9

I am trying to deploy a lightning web component to the org using vs-code but getting the error.

Starting SFDX: Deploy Source to Org

10:09:14.43 sfdx force:source:deploy --sourcepath d:\Aakriti\Projects\LWC\LWCLearning\force-app\main\default\lwc --json --loglevel fatal
10:09:25.813 sfdx force:source:deploy --sourcepath d:\Aakriti\Projects\LWC\LWCLearning\force-app\main\default\lwc --json --loglevel fatal ended with exit code 1

Earlier I was able to deploy components successfully but after updating vs-code, I am getting this error. I am not sure what is the issue. Can anyone please let me know how can I resolve this.

I am using api-version '45'.

Thanks.

3
  • 1
    Can you check if the error message is limited to What you have posted in your question? Check if you are getting anything else? – sanket kumar Apr 12 '19 at 5:23
  • @sanketkumar, No I am not getting anything else. It is not specifying the exact error message. – Aakriti.G Apr 15 '19 at 6:38
  • Is this a sandbox, developer org or production org? sfdx force:source:deploy is still in beta and is not available on production orgs developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/… – neff May 11 '19 at 22:29
18

I was also facing the same error but did not find anything here. If your deployment is failing, so you need to go to your developer org, setup --> Deployment Status Settings

Here you will find the error details. Mine was failing coz I had already one lightning component by "HelloWorld", so I had to delete it.

You might face some other error here. So please check and then try.

2
  • thank you, with your help I can at least see the actual error. BTW it is Setup > Deployment Status and not Deployment Settings. – SFDC Dev 27 Jul 24 '19 at 20:59
  • Yes exactly. Thats the issue but i was unable to delete the component so created a new component with a different name. – Dadhich Sourav Nov 6 '19 at 11:00
1

Try the execute the command from Terminal window of VS Code, by putting 'trace' log level. Generally, you can copy the command from the output window. Eg.

sfdx force:source:deploy --sourcepath "c:\Users\Ross\Documents\Personal Practice Orgs\gungunaDev\force-app\main\default\lwc\customPathUiLwc" --json --loglevel trace

On the terminal window, after running the command you get the detailed errors. In my case, I was having a different name for my folder and my Component files.

I got the message as below. Which said that you 'Cannot find Lightning Component Bundle'. After looking at the error I realized that somehow I changed the name of the folder but not the files.

enter image description here

0

Had the same problem. There is no specific error message after the '--json --loglevel fatal ended with exit code 1'

To have a more specific error message, use Salesforce CLI terminal: "sfdx force:source:deploy --sourcepath \force-app"

This gives an error of: "MissingMessageError: Missing message mdapi_deploy"

If we have the same problem, Uninstalling and installing Salesforce CLI should fix the problem

Not the answer you're looking for? Browse other questions tagged or ask your own question.