1

I can't push managed package bcoz I've deleted few unwanted classes from it and rebuild the package now whenever I try to push this new uploaded package it went fail and ask me for deleted class bcoz it's still refer in previous organization so now I can't create new class with same name nor push to customer I am stuck.

  • Were the classes you cleaned up "global"? – Phil W Apr 8 '19 at 11:01
2

I had the same issue in the past and order to fix I gone through the following steps -

1) Create a new managed patch version based on the installed version on subscribers org. 2) Update the removed classes with no code. Something like this

class ABC {

}

3) Remove all the references of the deleted classes from the code 4) Installed/Push the patch version on client/subscriber org 5) Now, install the version ( which you have already created in your package org ) and you will not see any error.

If you don't have patch org enabled, then please contact Salesforce support and explain the situation in a detailed manner and they will help you for sure!!

Good luck!

| improve this answer | |
  • Thanks naval its a great help . I make patch but no where i find push. how do it push it can i install through link and one more thing do i create managed package or beta version in patch – Parth Naik Apr 9 '19 at 14:11
  • Issue resolved @naval thanks for really great help at such a crucial time. – Parth Naik Apr 10 '19 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.