Problem with launching apex replay debugger. Cant even launch.

I have in vsc Salesforce Extension Pack and work with it.

  1. run SFDX: Turn On Apex Debug Log for Replay Debugger.
  2. get debug logs.(level everywhere is finest and I chose breakPoint)
  3. choose log file , right click and choose - launch apex replay debugger wiht current file. and get nothing.
  4. open command pallete choose this command and get error message

    command 'sfdx.launch.replay.debugger.logfile' not found

.vscode/launch.json :

"version": "0.2.0",
"configurations": [
    "name": "Launch Apex Replay Debugger",
    "type": "apex-replay",
    "request": "launch",
    "logFile": "${command:AskForLogFileName}",
    "stopOnEntry": true,
    "trace": true

Help please to find a solution. Thanks in advance.

  • I have not a scratch org but sandbox without DX. (forget to mention) – Nikita Mar 29 '19 at 9:23

I had the same issue. My fix, I just reauthorize the org. SFDX: Authorize an org.

After that, I'm able to turn on the replay debugger. SFDX: Turn On Apex Debug Log for Replay Debugger.


I ran into a similar issue... once you invoke "SFDX: Turn On Apex Debug Log for Replay Debugger." on your targeted salesforce org, Login to your instance via the web browser, navigate to the "Debug Logs" section under setup.

Sort the debug logs by the date that the logs expire. Ensure the logs are targeted at your user and not someone else. If it is targeted at your user, make sure to run any apex test classes or activity as your user. Adjust the user to be your own and then try to download the logs. It should then work

  • tried one more time. doesn't work( – Nikita Mar 29 '19 at 9:22
  • This one worked for me. I deleted all of the "User Trace Flags" and was finally able to turn on the replay logging (shows up as "ReplayDebuggerLevels1619793750797" in my "User Trace Flags" console). – jerhewet Apr 30 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.