2

Background

I get this error message:

ERROR: Cannot create an AuthInfo instance that will overwrite existing auth data.

In the VSCode output panel, when I try and run a unit test:

Starting Run Apex test(s)

22:07:35.724 sfdx force:apex:test:run --tests SalesforceReportApiTests.getMatrixReport_success --resultformat human --outputdir c:\projects\sfdx\xxx\.sfdx\tools\testresults\apex --loglevel error

I've tried re-authorising using this command:

SFDX: Authorize an Org

22:12:42.841 sfdx force:auth:web:login --setalias xxx --instanceurl https://test.salesforce.com --setdefaultusername

But it made no difference.

Running other commands like sfdx force:source:deploy work fine

Questions

  1. What is causing it?
  2. How do I fix it?
  • I am getting this error as well. Just started about 10 minutes ago. Tried creating a new scratch org as well but even though it created it and pushed, I still got the same error trying to assign a permission set to my user. Also tried updating SFDX (was on the latest version) and there are no updates to VS Code or Salesforce Extensions available. – SfdcHawkeye Mar 25 at 22:32
0

This issue resolved itself after ~12 hours.

I assume there was an issue with the Salesforce platform which has now been fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.