0

I am using SFMC Rest API to send SMS. I have used API Trigger send type in mobile connect with outbound message template. I am using postman.

Prob : Below is the URL which i am using in the postman to trigger the sms. https://yourdomain.rest.marketingcloudapis.com/sms/v1/messageContact/{APIKEY}/send

In response i am getting a TokenID and according to documentation if the request is valid then you get this tokenid. But i am not getting the SMS.

On checking the status using the URL mentioned below which utilizes this tokenID. response is "Unknown"

https://yourdomain.rest.marketingcloudapis.com/sms/v1/messageContact/{APIkey}/deliveries/{TokenID}

if anyone knows please help here.

See the request below :

{ "Subscribers": [ { "MobileNumber": "9199xxxxxxxx", "SubscriberKey": "123456789" } ], "Subscribe": "false", "Resubscribe": "false", "Override": "false", "SendTime": "2019-03-25 18:59" }

Thanks

  • Can you share the payload you are sending? – Rafał Wolsztyniak Mar 25 at 13:53
  • @Rufenstein, see the updated text with request above. – R Suri Mar 27 at 12:49
  • have you checked if you have the right API permission set to send the SMS in installed packages? – Brad Sapkota Mar 28 at 12:41
0

Please check if the contact you are trying to reach exists in Mobile Connect.

You have "Subscribe":"False" setting enabled and you shouldn't be able to send to the mobile number if the contact isn't already there.

If you switch this value to "True", when the API call will reach Marketing Cloud it will create a new MobileConnect contact and a subscription on a given keyword (when this setting is true, you need to include a keyword parameter).

All in all you have two options:

  1. Create the contact you are trying to reach in MobileConnect
  2. Switching "Subscribe" to "True" and adding a keyword parameter that will create a contact and subscription in MC.
  • Thanks for your comments!! Because subscriber had been added manually, the status field was not getting populated. After assigning code and keyword to add subscription of the contact in the contact builder, the problem resolved. Thanks everyone. – R Suri Apr 5 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.