1

How to Solve this issue to Import record

SOURCE: 'fsCore__Customer_Name_Format__c' DESTINATION: 'fsCore__Customer_Name_Format__c' ERROR:bad value for restricted picklist field: Account Only

Here is picklist which I want to add into another org

picklist Of Customer Name (Title) Format

Another Org PickList

Second Org picklist Another Org

Second Org

  • 1
    Do you have record types on Account? Is that possible that given picklist value is not assigned to recordtype of mentioned record? – kurunve Mar 25 '19 at 10:19
  • Yeap it should be because of respective record type configuration only. – Basant Kumar verma Mar 25 '19 at 11:47
  • Guys, Solve my issue. The problem I Faced because picklist Of Customer Name (Title) Format is Depend on Customer Type Picklist value.Our Old Org don't have Customer Type but in new created So I add column(Field Name - Customer Type ) in excel . Thanks to everyone – Tarsbir Singh Mar 27 '19 at 12:18
0

As @kurunve said this may be due to the picklist value not being available on the record type.

If that is not the case, A possible solution you might consider is to un-restrict the picklist values (temporarily), do the import and then re-restrict the picklist field. This Should allow you to complete the import. I encourage you to then try updating the imported record and see if the same error is thrown and then you can debug further. I ran into similar problems with picklist api names containing [multiple] spaces and was not able to find a permanent solution yet.

| improve this answer | |
  • They won't be able to un-restrict in this case, because the field is from a managed package. – Thomas Taylor Mar 25 '19 at 20:31
0

In my case, there were Field Dependencies set up. So even though the value was active in the picklist, I eventually learned that the combination of that value with the controlling field's value was not valid.

From the Object Manager > the custom object you are getting the error on > Fields & Relationships > there is a Field Dependencies button at the top right of the list of fields.

Once I found and edited the field dependency to include the value, I was able to load the records from Data Loader.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.