0

I am trying to get to the Forgot Password page in my Lightning Community because it currently has a typo on it. When I am in Builder & try to go to the page, it just hangs and never brings up the page. I have tried this in Firefox and Chrome. I am not having this problem with other Community pages.

1

The Community Builder will execute the init method of all custom components on a page when you try to view it in the builder. If there is a failure in any of the init methods, you may not be able to view the page properly.

Also, if an init method does a redirect in certain situations, you may find that the builder forces the redirect and so you cannot view the original page.

The workaround is to temporarily comment out the init methods of the custom components on the page so that the builder can display the page.

| improve this answer | |
  • David...how do I see what components are on the page if I can't get the page to come up in Builder? I understand what you are saying about commenting out the init. However, I don't know which components are coming into play at the momen. – Michele Kleinhomer Mar 25 '19 at 2:44
  • Actually I see the components. I can access that part of the page. I will try commenting out inits. – Michele Kleinhomer Mar 25 '19 at 2:52
  • Well, I still need help. I can see that the Forgot Password Community page has 4 components on it. Three are rich content components and one is a Forgot Password component. When I create a new test Community page, I don't see an option to add the Forgot Password component to it. When I look at the inaccessible Forgot Password Community page via Builder, I can see that there is an Identity Forgot Password component. I am not sure how to see this component. I don't see it in the Developer Console. – Michele Kleinhomer Mar 25 '19 at 3:13
  • I Builder next to the Forgot Password component on the page, it just has a trash can. It doesn't have the normal option that components have where you can click it and you will be taken to the component in the Developer's Console where you can see the code. – Michele Kleinhomer Mar 25 '19 at 3:15
  • I just created a new blank page variation of the ForgotPassword page. It has no components on it & it is hanging. I can't get to the page to add components, etc. – Michele Kleinhomer Mar 25 '19 at 3:19
1

I contacted Salesforce & they emptied my Sites.com trash can to resolve the issue. When I probed about how I can do this, I was told it can only be done by Salesforce. Below is the response...

You have a new comment on Case #22179008

Salesforce Support March 25 at 8:00 PM EDT Hello Michele,

I apologize but the information regarding on how to empty a trashcan is internal information so I won't be able to share it with you.

As for the reason, I believe that you have added a custom component with the page then when you have removed it, some data was not removed so emptying a trashcan solved the issue.

Let me know if you still have any issues or concern regarding the case or if we can now proceed with closing this one.

In case of no response, my next case update will be tomorrow between 10am - 12pm Eastern time.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.