-1

I have created a formula field on an object (Object_A__c) which needs to get the data from another Object (Object_B__c). The relationship is such that both objects A and B have lookup relationship with each other.

The formula field has been created successfully however on the record detail page, the formula field shows blank.

I checked all the premissions and checked the field from Object B whose data has been rolled up but the data still shows blank on Obejct A's record detail page. I also ran a query on workbench but the data is visible on workbench. Not sure why not on SF. There are other lookup/Master-Detail fields (say Object_C__c) in Object A whose data is being rolled out if used in a formula (like Object_C__r.Name). But not in case of Object B.

Below is the Text type formula field I have created to fetch the data. Object_B__r.Message__c.

9
  • 1
    Did you include the formula field to the page layout ? – Vijay Ganji Mar 18 '19 at 13:06
  • 1
    I believe the field is shown, that is happening that the value is blank. It could be a null or blank value on part of the formula – m Peixoto Mar 18 '19 at 13:20
  • Have you checked the user permissions on the Object_B__c field(s) being used by the formula? – AvailableName Mar 18 '19 at 14:08
  • @VijayGanji Yes the formula field has been added to the page layout. mPeixoto The value is not blank on Object B's field (the one from where the data is being rolled up om formula field). AvailableName Yes permissions are fine. Even Sys Admin is not able to see the data in the formula fields. – Salesforce Learner Mar 18 '19 at 15:17
  • your question is very generic, with this information is not easy to help you – m Peixoto Mar 18 '19 at 15:24
1

Your question is indeed quite generic.

I believe that if you reference a cross object field in a formula field, users will be able to see the value of the formula field even if they do not have permissions to access the related object [or field level security]:

https://help.salesforce.com/articleView?id=customize_cross_object.htm&type=5

so this is probably not due to permissions.

Perhaps your formula expression has valid syntax (allowed you to save), however it is not written properly to return the value you are looking for. Please provide more information such as the formula you are using for the field and perhaps the details of the roll up field on Object_B__c. This will help us more clearly understand the problem.

please refer to How do I ask a good question for future posts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.