1

I have an issue with SMS sending from journey builder where the history shows "Failed - object reference not set to an instance of an object" for the SMS send activity for all contacts and they don't proceed further.

The data extension consists of the following fields:

  • ContactKey (Primary Key)
  • Email (Required)
  • Phone (Required)
  • Locale
  • Name
  • Lastname

Further configurations:

The Journey is configured to use phone and email from the entry source. Contacts do not yet exist at the time of injection. The entry mode is set to "re-entry anytime". The journey runs once on activation of a new version. The journey sends:

  • Simple SMS with all contacts being subscribed to a defined keyword
  • Simple text-only email

The entry data extension is not otherwise linked to the data model (attribute set or population).

In earlier versions without the email field in the data extension and email activity) worked without any problems.

Removing the email components didn't help.

Creating a completely new journey with the same components also didn't work.

Does anyone have an idea what the reason might be that the SMS activity suddenly fails after the email parts were added without changing the SMS components? I'm

Thanks a lot!

1
  • I will check the steps in the linked thread tomorrow. What makes me scratch my head is that the same activity worked without issue before I added the email to the journey. The contacts didn't unsubscribe in between (they are actually me) Mar 13, 2019 at 17:45

0