0

I want to experiment sfdx,so I'd like to link a playground I just created from my Trailhead (because I already linked my first playground)

The fact is, the password seems to be different from my first playground and this new one ??

I'm using :

sfdx force:auth:web:login -r https://brave-raccoon-362177-dev-ed.lightning.force.com -a "Playground 1 Brave Racoon"

This first playground (curious-moose-283525) works fine : enter image description here

The commandline opens what you can see there : enter image description here

Seems good to me, but the password isn't the same, Am I missing something ?

Thansk !

EDIT : I set a password for my playground, but got an error with port 1717. I'll check furthermore for it later

enter image description here

1
  • Dev Hub is authorized (it's ok for other playgrounds, same trailhead account !) Commented Feb 27, 2019 at 12:23

1 Answer 1

2

Trailhead Playgrounds aren't scratch orgs linked to your Dev Hub. They're closer to independent Developer Editions.

To authorize them for use with Salesforce DX, you need to first get your Trailhead Playground username and password. Each Playground will have an independent set of credentials. You can then authorize each Playground separately with

sfdx force:auth:web:login -a MyPlayground
3
  • Thanks David ! I did it, but it seems I got an error with the port used ... 1717 I'm editing my post. Think I'll restart my computer, because it's away of my knowledge. Commented Feb 27, 2019 at 14:04
  • This article should help me, I'll try ! developer.salesforce.com/docs/atlas.en-us.sfdx_dev.meta/… Commented Feb 27, 2019 at 14:12
  • 1
    I think that error will resolve in a restart, @AlexisMASSON.
    – David Reed
    Commented Feb 27, 2019 at 14:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .