1

screen shot from the phone

OK so I have a Galaxy Note 3. I installed the Salesforce1 app on it and when I view records in our production org, everything looks fine. Then when I log into my development org, the display is incorrect and I can't properly view account records. Any ideas of what I need to do to fix this? I need to test some Visual force components to make sure they display the way I want them to in Salesforce1. The view using the web app by appending one/one.app to the URL doesn't even look or quite act the same as what I see in the production org.

7
  • I wonder if it could be because I don't see the Salesforce1 app loaded into my org. Jan 27 '14 at 15:23
  • 1
    I'm a bit confused by the question. Are you able to login to your test org with the Salesforce1 app? (so when login in, you selected the sandbox server etc?) Also, please clarify what you mean with the "display is incorrect". Another thing that you want to be sure of is that your production and sandbox org are in sync.
    – KoenVM
    Jan 27 '14 at 15:29
  • Yes I can log into my sandbox just fine. When I look at the account information, it doesn't show properly. Labels and values are all superimposed on the bottom of the window, buttons don't have labels and are very small. The google one works but that is about all. The names listed in the menus for the objects looks OK but when I navigate to one of the records, the display is all wrong. Kind of like some style sheet information is missing. Jan 27 '14 at 17:04
  • It looks OK when I log into the production org. Also a coworker can log into my sandbox using an iPhone and the view looks OK though a VisualForce page I need to work on crashes the app. Jan 27 '14 at 17:11
  • Is there a way to attach a screen shot from my phone? That might help a lot by showing how the display is wrong. Jan 27 '14 at 18:23
0

Aha, I see now. Someone already posted this same issue too. (the issue where the stylesheets were not being applied) What fixed the issue then was re-installing the application. I would say, have a try.

7
  • The web version looks better but when I try to navigate to the account list, it hangs. Jan 28 '14 at 14:07
  • Getting in and out of the truck sort of worked. When I can finally get to the desired account page, the buttons don't work. I have a custom button that is supposed to direct the user to a VisualForce page but when I tap on it, nothing happens. Jan 28 '14 at 14:09
  • Your custom button + VF page worked before on your device? Does it work on the Salesforce1 browser app? Are you testing on wifi or 3G? (when it's a big VF page, it might just take a while to load)
    – KoenVM
    Jan 28 '14 at 14:33
  • KoenVM, I couldn't even get to the VF page. The account layout didn't load correctly. I did as you said and reinstalled the Salesforce1 app and now I can get to the VF page. Funny thing is I can't scroll down the page. Jan 28 '14 at 14:40
  • ok, so on Salesforce1, your account now looks OK again, your button is working and opening the VF page but your VF page now has an issue and won't scroll? Haven't had any issue with scrolling on a visualforce page in Salesforce1 though. If that is your last issue, I suggest posting a new question specific to the scrolling issue in Salesforce1 as this is not realy related anymore to your original question.
    – KoenVM
    Jan 28 '14 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.