1

I have some question on setting up SAP.

My IT Team says they have created a 'CNAME' and delegated a sub-domain 'survey.abc.com' to exact target name servers.

Delegating Domain

But, while am configuring SAP it gives me an error "Required delegated nameserver ns2.exacttarget.com not found."

Does anyone face the same or how to resolve that ?

Thanks in Advance.

2

You need to delegate the domain using NS records, not CNAME. CNAME only "masks" ns2.exacttarget.com behind your SAP domain, but you still remain in ownership of it. Delegating requires your IT team to delegate the entire subdomain, and you can only have your SAP DNS entries managed by Salesforce.

There is a good article here, explaining the details of how this must be done.

If you want to keep hosting the DNS entries yourself, and possibly also have additional records created, there is an option of self-hosting. Here Salesforce will provide you with a list of entries to add to your DNS settings, to have all point to the right domains/IPs. However, if e.g. an IP is later changed by Salesforce, you will be notified and will need to update your DNS accordingly. This will not be needed if the subdomain is delegated.

Here is a "sample" list of settings you need to maintain, if you choose to self-host the DNS.

I will recommend full delegation anytime, as this is a one-off task, and leaves Salesforce with the responsibility of keeping the DNS records up to date.

  • Hi @Lukas Thanks for your reply. We are delegating the domain using NS record only.We are planing to manage the DNS entries by salesforce only. Am getting same error. – razor Feb 25 at 8:01
  • But the screenshot you provide, clearly states the type of entry is CNAME, not NS – Lukas Lunow Feb 25 at 8:05
  • I know am bad at networking, but please help me to understand is there any record type named 'NS' ...i can see 'A', 'txt', 'MX', 'CNAME' as record types. – razor Feb 25 at 9:05
  • Yes - similar to the CNAME, you should be able to select NS. If you can't, then you might be missing permissions or similar. Please reach out to your IT team, who should be able to assist you, when provided with this guide – Lukas Lunow Feb 25 at 9:07
  • 1
    Thanks Lukas for your help. IT team has added 'NS' record type and delegated to exact target name servers. Now we have enabled the SAP. – razor Feb 26 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.