0

Facing problem to complete this trailhead trail ( https://trailhead.salesforce.com/content/learn/projects/quickstart-vscode-salesforce/use-vscode-for-salesforce )

I have installed Salesforce CLi and Vscode properlly.

When i am creating project from terminal or from shortcut ctrl+shift+p and mention the name of project it is throwing error.

Is there any path i have to set in "My computer" Advanced setting or something else.

sfdx force:project:create --projectname VSCodeQuickStart

sfdx : The term 'sfdx' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. At line:1 char:1 + sfdx force:project:create --projectname VSCodeQuickStart + ~~~~ + CategoryInfo : ObjectNotFound: (sfdx:String) [], CommandNotFoundException + FullyQualifiedErrorId : CommandNotFoundException

2

The PATH is the system variable that your operating system uses to locate needed executables from the command line or Terminal window.

You need to set the path in Environment Variable by following the below process:-

  • From the desktop, right click the Computer icon.
  • Choose Properties from the context menu.
  • Click the Advanced system settings link.
  • Click Environment Variables. In the section System Variables, find the PATH environment variable and select it. Click Edit. If the PATH environment variable does not exist, click New.
  • In the Edit System Variable (or New System Variable) window, specify the value of the PATH environment variable. Click OK. Close all remaining windows by clicking OK.
  • Reopen Command prompt window, and run your sfdx command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.