My Community Guest can see files in the Asset Library. How can I change this?


Below is the ScreenShot .Click on Edit Members.From there you can deselect Public groups,Standard or individual users. enter image description here

  • No members show as having access to the Asset Library yet everyone can access the files in it. – Michele Kleinhomer Feb 17 at 13:22
  • Try removing access to Chatter and Documents object to the community users – Nikita Gupta Feb 18 at 6:00

I found that if your Community is open to the public or if you have any Community public pages that a Community setting called "Let guest users view asset files on public and login pages" gets set automatically. This allows guest users to see any asset files that are on public/login pages & files that are inserted into rich text fields. This is a problem if you have rich text fields on authenticated only pages. The guest users get access to the files in them (via a URL) regardless of the library they are part of. To resolve this, remove the checkmark next to "Let guest users view asset files on public and login pages" and assign the Guest user view rights to the Asset library or the library you designate to be the one that Guest users will see.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.