2

I am using a triggered Send SMS that is called from SFDC through trigger using REST API. When user responds 'STOP' I want that SMS should not be sent to that user(i.e the contact in MobileConnect whose subscriberKey is set from REST request) from MobileConnect. How can this be achieved?

I could not find opt-out option anywhere in MobileConnect.

1

STOP is default keyword in Mobile Connect - you don't need to implement it and you are not able to disable the functionality. You can read more about them here.

To be able to respond or opt-out the customer needs to know the long code (sender mobile number) that was used by your communication. If this number is available and the customer successfully sends to your sender number, she/he will be fully opted-out from communication from this number (the subscription status on all keywords will be set to "not opted in").

In the payload that is used to send SMS, you have three important values related to the subscription status:

  • subscribe
  • resubscribe
  • keyword (required when "Subscribe": "true")

There are a few cases that are possible:

  • "Subscribe": "false" - only send to contacts that already exist in Mobile Connect
  • "Subscribe": "true" - create a mobile subscription if the customer does not exist (you need to then add the "keyword" value). The "not opted in" status will be respected and the text message won't be delivered
  • "Subscribe": "true", "Resubscribe": "true" - This creates the customer in Mobile connect where not available already and should change the subscription status, but this does not work when I tested it (the status stays opted-out)

In your case I would recommend using "Subscribe": "true" without the resubscibe parameter.

  • Oh, your first line of answer makes it so much clear for me. Just one question, do we need to create a new STOP keyword as mentioned in docs? – Sarang Feb 13 at 11:26
  • 1
    It's really not necessary. You can do so, if you want to for example create a local language version of the STOP keyword. – Rafał Wolsztyniak Feb 13 at 11:36
  • When I receive the SMS, it shows me that it is sent from a number that is different from the short/long code that is embedded in my outbound template. So, if I reply STOP to that I am not opted out and I again get the message. Is my understanding correct, if not please enlighten me. – Sarang Feb 14 at 5:34
  • Are you in the same country as the long code? – Rafał Wolsztyniak Feb 14 at 7:38
  • No. But I am using google voice and have it configured for a USA number. Is the long/short code predefined country wise? – Sarang Feb 14 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.