8

With the latest CLI (sfdx-cli/6.52.2-c6cdc99881 (darwin-x64) node-v8.9.4) i have observed that the mdapi:source convert fails when the package has the lwc bundle .

The salesforcedx plugin version is salesforcedx 45.1.2

Steps to reproduce

  1. Create an unmanaged package in Developer Edition org with lwc bundle and retrieve src by package name or clone the git repo here https://github.com/msrivastav13/mdapi-convert-lwc-bug.git

  2. Source convert it using below

    sfdx force:mdapi:convert -r ./mdapiout -d force-app

The error in the console is as below

An error was encountered processing path: /Users/mohith/Desktop/Projects/DemoApplication/mdapio ut/src/lwc//.html.

Here is the complete log for more info.

https://textuploader.com/1a8hn

Anybody else facing this or it's just me ?

  • 2
    I am getting the exact same error with the exact same version of Salesforce DX – Bill Appleton Feb 11 at 20:03
  • no, you're not the only one. I've got the exact same error too. anyone hears from Salesforce on this ? – codeinthecloud Feb 14 at 11:49
  • 2
    They working on the fix .No updates yet . – Mohith Shrivastava Feb 14 at 15:57
1

This issue was fixed by salesforce CLI team .

enter image description here

Its also good to bookmark the CLI release notes url.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.