1

Users are unable to login to Salesforce from outlook if these users have a login flow for their profile. Has anyone experience this ? If so, what did you do?

Seems like an issue with Salesforce login flow/ outlook integration?

2

While I agree that seems like an issue (aka a bug), you should be able to parse the user agent in the login flow or the platform to determine if they are coming from outlook and bypass the login flow in that case.

See this article for the variables that you have access to in your login flow. Will take some experimentation / analytics to determine the best values to filter on, but should be possible to bypass the flow for outlook client and will take less time than logging a support case (and you may get shut down bc you need premiere support for visual workflow issues).

Copying the variables below for reference.

LoginFlow_LoginType

LoginFlow_IpAddress

LoginFlow_UserAgent

LoginFlow_Platform

LoginFlow_Application

LoginFlow_Community

LoginFlow_SessionLevel

LoginFlow_UserId

  • Thanks @gorav for your suggestion. I will try to bypass the outlook logins from the flow. You are right, about being shut down for not being a premier support account. – user4947 Feb 11 at 14:42
1

Salesforce has acknowledged this as a bug, and are currently working on it. the expected release is Summer 19 (safe harbor)

  • I'm also having the same problem. @user4947 - What are you basing that on? This is all I could find on the Salesforce 'Known Issues' site: success.salesforce.com/issues_view?id=a1p3A0000003UnkQAE I also wasn't able to find anything related to this in the Summer '19 release notes. – M H May 8 at 11:29
  • @MoH I am basing that on the response i received from Salesforce for my ticket, and the telephone conversation I had with Salesforce Support. – user4947 Jul 29 at 13:39
0

Is there a solution to this ... Basically when we try to login to Salesforce via Outlook it renders it via default browser ... IE in most cases... On checking even neither login type now user agent doesn't contain 'outlook' reference making it hard to be able to login via Outlook when we have the login flow to block IE access to Salesforce enabled... Appreciate if anyone has been able to find a solution to this problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy