2

When I am trying to make a beta release. I am getting following error:

No COMPONENT named markup://Namespace:ligtcomponent found

Can any one please help me out of this.

I have seen this below link that this issue have been resolved by salesforce. SalesforceDoc

1
  • can you give more details? There are some standard lightning components that will require the package namespace to be used. Such as force:recordData, this will require the namespace of the package to access any custom objects / fields Mar 7, 2019 at 9:42

2 Answers 2

4

I ran into this today, it looks like it is popping up again recently.

I can't offer any science but I did get past it.

If it's happening to you, try deleting all code in the offending component (between the component tags but not the tags themselves) and then upload the package again, fingers crossed and you will get no error. Then paste the same code back in, save the file and uploaded again.. this worked for me.

// edit

the bad news: It may not be a permanent solution, for me the error intermittently returns, hopefully SF will fix the root cause soon.

the good news: you may not need to actually upload the package (with the code deleted) for this to work. Simply deleting, saving the component then pasting back in and saving again seems to work just the same.

1
  • @DanielCollier Thank you so much for this
    – Eric
    Mar 10, 2019 at 3:46
1

In your packaging org, you use the default namespace c. This makes it easier to migrate code between your packaging org and any developer orgs you may be using.

1
  • We were trying to release beta package. we have raised a case with salesforce so they replied like it's Known Issue.
    – Jay
    Feb 7, 2019 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.