1

I have the following web2lead form where I add a recordtype. On submit it still generates a default lead recordtype. Am I missing something?

<META HTTP-EQUIV="Content-type" CONTENT="text/html; charset=UTF-8">
<form action="https://webto.salesforce.com/servlet/servlet.WebToLead?encoding=UTF-8" method="POST">
<input type=hidden name="recordType" id="recordType" value="0121t000000Qf3qAAC">
<input type=hidden name="retURL" value="https://www.xxxxxxx.com/">
<label for="first_name">First Name</label><input  id="first_name" maxlength="40" name="first_name" size="20" type="text" /><br>
<label for="last_name">Last Name</label><input  id="last_name" maxlength="80" name="last_name" size="20" type="text" /><br>
<label for="email">Email</label><input  id="email" maxlength="80" name="email" size="20" type="text" /><br>
<label for="phone">Phone</label><input  id="phone" maxlength="40" name="phone" size="20" type="text" /><br>
Message:<textarea  id="00N1t00000K2v9Q" name="00N1t00000K2v9Q" rows="5" type="text" wrap="soft"></textarea><br>
<input type="submit" name="submit">
</form>
6
  • Have you verified the profile of the default creator for Web-to-Lead settings to see if the profile has access to the record type mentioned as in the form or not?
    – Jayant Das
    Jan 30 '19 at 15:27
  • @JayantDas I did this is a system admin profile
    – Thomas
    Jan 30 '19 at 16:41
  • So does the system admin profile has the record type assigned?
    – Jayant Das
    Jan 30 '19 at 16:43
  • @JayantDas The profile has all the recordtypes assigned but there is 1 default recordtype. On creating a new lead I can select all recordtypes
    – Thomas
    Jan 30 '19 at 16:46
  • Well not quite sure then, you may like to verify if there are any triggers/workflow updates, etc. on the Lead record which could be possibly changing the record type.
    – Jayant Das
    Jan 30 '19 at 16:50
1

For all who bump into this issue. I had the recordtype assigned to the profile. Another step that needs to be done is on the Lead setting put this setting on:

  • Keep the existing record type

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.