1

I have a Visualforce page that uses $Lightning.createComponent to handle Lightning component. This page has standardController="Account" and used as replacement of standard action "Create new Account". As a result it just provides more flexible form for creating new Accounts and works well on Sandbox.

But it has issues after moving on Production. I see next message on background:

This page has an error. You might just need to refresh it. afterRender threw an error in 'lightning:dualListbox'[Cannot read property 'filter' of undefined] Failing descriptior:{lightining:dualListbox}

I have two dualListboxes on the component, here they are:

                        <div class="slds-col slds-size_1-of-1 slds-m-bottom_medium" hidden="{!!v.renderedFieldsForRecordType.PartnershipType__c}">
                            <lightning:dualListbox  name="PartnershipType"
                                                    aura:id="fieldId"
                                                    sourceLabel="Available"
                                                    selectedLabel="Selected"
                                                    label="{!$Label.c.Contact_Partnership_Type}"
                                                    options="{!v.pickListValues.PartnershipType__c}"
                                                    value="{!v.selectedRecord.PartnershipType__c}"
                                                    required="{!v.renderedFieldsForRecordType.PartnershipType__c}"
                            />
                        </div>
                        <div class="slds-col slds-size_1-of-1 slds-m-bottom_medium" hidden="{!!v.renderedFieldsForRecordType.ProductLine__c}">
                            <lightning:dualListbox  name="ProductLine"
                                                    aura:id="fieldId"
                                                    sourceLabel="Available"
                                                    selectedLabel="Selected"
                                                    label="{!$Label.c.Contact_Product_Line}"
                                                    options="{!v.pickListValues.ProductLine__c}"
                                                    value="{!v.selectedRecord.ProductLine__c}"
                                                    required="{!v.renderedFieldsForRecordType.ProductLine__c}"
                            />
                        </div>

It looks like Lightning internal issue because I don't use any property 'filter' in my code. Also I've checked all capitalization of attribute requests etc.

  • I would imagine that your sandbox and production are on different release versions, have you tried reaching out to the Salesforce support? – Jayant Das Jan 22 at 22:37
  • Can you check the version in metadata in each environment? – Raspi Jan 26 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.