Account Name is not visible the Approval Process record. Can you tell why this maybe happening?

1. In 1st image, Account Name is visible in List View.
2. But when I open specific record, account name is not visible.

I am not able to understand why? Please help!!!

  • 1
    From your ListView the field name is Related Too.. can u check that? – Pranay Jaiswal Jan 22 '19 at 14:35
  • @PranayJaiswal Yeah i have checked that...See when I do the same in my another ORG, account name is visible. But if do same process in this ORG, account name is blank.....Cant understand?? – user62549 Jan 23 '19 at 2:31

If the field is blank then it must not be the look up field that is showing up in the related list view. Please navigate to the object settings and confirm the field label and type. It is likely that the Account Name field is not the lookup field that is referenced in the specified list view, so you will want to update your page layout.

  • The Approval Process Object has no page layout...And when I do the same in my another ORG, account name is visible. – user62549 Jan 23 '19 at 2:29
  • Misnomer on my part the approval page layout is set here by navigating to Setup > Process Automation > Approval Processes > Approval Process Name > Edit > Approval Page Layout. The issue is likely that the wrong field is used in the Approval Page Layout? In the record layout is the field called the Account Name? Perhaps a field update/wfr/flow or process aren't transfering the text to the name field. If the issue persists after reviewing the Approval Page Layout, please confirm the field type for the account name on the _____ object. – Gabriel M Jan 23 '19 at 18:18

I know I am late to answer this question, but this is now a known issue that can be found here: https://success.salesforce.com/issues_view?id=a1p3A0000018C43QAE

The issue only impacts Orgs that have person accounts enabled. I created a very crude workaround until Salesforce fixes the issue. I created a new Account text formula field using this formula:

HYPERLINK("/"&Id, Name, "_blank")

I added that new field to the approval page layout. That solves the issue for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy