In a Winter '14 Developer Edition and Spring '14 Pre-release I have noticed that using the Developer Console uses API calls. It looks like this affects third party tools like MavensMate as well. The limit for a Developer Edition is 5,000 / 24 hours and I've used about 125 in a 20 minute period. This is without running unit tests. Running unit tests burns through the API calls even quicker.

Add in another developer, code that uses the API, and frequent unit test execution and the limit can be hit without much effort.

Is there any configuration that I can make to not use as many API calls with the Developer Console? Perhaps, some features that I can disable?

It's possible that it is related to this Idea about the Tooling API and limits.

  • 4
    Tooling API calls need to have their own limit and it needs to be drastically higher. Although it is possible that MavensMate was causing issues, but I was able to run through a bit over 5000 in under an hour last night. That seems insane. Jan 21, 2014 at 13:51
  • I would hope that the dev console, at least, wouldn't cost api calls. After all if that's the supported dev environment, you'd think it'd be non-costly
    – Kevin P
    Jan 21, 2014 at 15:35
  • @KevinP - The Developer Console is definitely using API calls. You can run the standard report "API Calls Made Within Last 7 Days" and see the numbers increase with the Developer Console open. When tests are run from the Developer Console they go up dramatically (one per test class/method?). Jan 21, 2014 at 15:55

1 Answer 1


You can reduce your API usage by allowing your developer console session to "idle". Once idle, you'll only incur one API call per incident (such as saving a class, running a test). While not idle, the current implementation polls the server once every 6 seconds, or 10 API calls per minute while doing absolutely nothing.

Also, using the Force.com IDE will drastically reduce your API calls, because you won't suffer from the "monitoring" API calls. Believe it, it makes a big difference.

For those interested, I asked this myself on the Salesforce Community:

@Josh Kaplan (Salesforce.com), in addition to the code coverage glitches in the API, your comment https://success.salesforce.com/ideaView?id=08730000000kuJtAAI about retiring the setup pages in exchange for the Developer Console is worrisome. Today, using the console consumes one API call per six seconds per developer. Given that a normal developer org has 5,000 calls per day, this means that two developers working in the same organization (the maximum a normal developer edition supports) can only work for 4 hours a day actively in that organization before exhausting their daily usage limits. If we are required to use the console, we will be limited to working just a few hours a day inside the platform. Is there any plan to have the console no longer use API calls?

Josh Kaplan (SFDC PM) had this to say:

Starting with the coming release the number of API calls will dramatically decline. Results will be streamed, so polling will not consume so many API calls.

Presumably this applies to Spring '14.

  • Any idea how to actually make the developer console session idle? Is there a setting or something for that? Jan 21, 2014 at 19:03
  • 1
    @JesseAltman It times out after a period (15 minutes?). If you purposefully disrupt your Internet connection before a poll, that should also inactivate it. It also appears that the system now checks once every 30 seconds for updates instead of every 6 seconds, so it now uses just 20% the API calls.
    – sfdcfox
    Jan 21, 2014 at 19:15
  • Hopefully SFDC is still working out the kinks for the upcoming Spring '14 release. I've developed for about the last 2 hrs in a Spring '14 pre-release using the Developer Console and used about 1,000 API calls. I have to use the Developer Console. IDE's not available for API 30. No option to edit the classes through the web interface or the dev mode footer. Jan 21, 2014 at 21:06
  • I had it happen to me with MavensMate too, related to the tooling API. With MavensMate you can turn it off: github.com/joeferraro/MavensMate-SublimeText/issues/347. Apr 22, 2014 at 20:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .