0

enter image description hereI have moved account records through data loader, but all attachments, files, record type are not showing in my target org, only account name and some other fields are showing. Can you please help me in this thanks in advance.

  • Did you get any error while loading attachments/files? You can refer the success and error files which you get from dataloader. – Reshma Jan 17 at 6:11
  • No in my target account item is created, I have created the external account id to match with source id – Dev bluCursor Jan 17 at 6:30
  • If you have loaded attchments/files in your target org successfully, check record ids available in the success files and verify those are mapped to correct parent id. – Reshma Jan 17 at 6:36
  • In my success report, record id field is showing but in the parent Id it showing blank – Dev bluCursor Jan 17 at 6:59
  • 1
    You have to map parent id field of attachments before inserting them to database. – Reshma Jan 17 at 7:07
0

There are following points to verify:

  1. Object level access: User should have Account object access, which you already has.
  2. Field level access: User should have View access in their profile.
  3. RecordType access: In user's profile, recordtype should be assigned.
  4. Record level access: Record must be shared to the user to view or edit, based on sharing rules and other ways.
  5. Page Layout Assignment: User's profile, recordtype and page layouts to be correctly mapped.

Since, for files and attachment object get inherent access based on parent access so, if user has access to Account then related child records will have access. Be sure to put related list in the page layout for your verification.

Note: Correct Id and ParentId needs to available and mapped during data upload.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.