0

I have to create a test class for a flow and I wanted to check the flow test coverage for it. https://releasenotes.docs.salesforce.com/en-us/winter19/release-notes/rn_forcecom_flow_test_coverage.htm

an Error has been displayed saying that FlowTestCoverage is not supported. any Idea here ?

  • What steps did you take that led to that error? – David Reed Jan 14 at 13:22
  • This step : To calculate the overall test coverage for a flow version, query the FlowTestCoverage object. The FlowElementTestCoverage object is not used to calculate test coverage. – mayMay Jan 14 at 13:30
  • Are you trying to query this object through the developer console, an Apex class, or through some other method? If it's an Apex class, you'll need to ensure that the API version for that class is >= 44.0 – Derek F Jan 14 at 13:47
  • yes Exactly, I am trying to execute it from a developper console with an API version = 44, but I am having this Error. – mayMay Jan 14 at 13:53
3

The FlowTestCoverage object is only supported in the Tooling API, so if you're running the query from the developer console, you should check the 'Use Tooling API" box next to the "Execute" button before you run the query.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.