I have created a Data Extract activity exports a .csv file containing records from my Data Extension.

The file is in the wrong File Format so I have requested Salesforce activate additional encoding options in my Data Extract activity which they have. They advised using the "Custom UTF16 to UTF8 Encoding" to convert to the correct csv format.

After my initial Data Extract, I created another Data Extract activity which follows straight after to convert the file (not sure why this cant just be done in the same step to be honest), but either way the second Activity which is supposed to convert the file fails. The file is exported straight to the safe house so I'm not sure if its a location issue, and i can confirm the file name patterns are correct.

Any ideas?

1 Answer 1


I did a file export from a dataextension like this:

DataExtract Activity1:

Pattern: TEST_SAFEHOUSE_%%Day%%%%Month%%%%Year%%.csv
ExtractType: Data Extension Extract
Column Delimiter: ;
Has Column Header: Yes
Uses Line Feed: Yes
Text Qualified: No

DataExtract Activity2:

ExtractType: File Convert
ConvertTo: UTF8
Is File in SafeHouse: True

File Transfer Activity:

Pattern: TEST_SAFEHOUSE_%%Day%%%%Month%%%%Year%%.csv
File Action: Move a File from Safehouse
Destination: A Location you have configured

It is very important that your column delimiter on step1 is the delimiter in your local settings of your operating system. When the operating system has a different defined you might end up with problems on excel (if you use it).

Does this help or do you really have to use the UTF16 to UTF8 Feature?

  • So it looks like I should be using File Convert instead of "UTF16 to UTF8" as advised by Salesforce. Commented Jan 11, 2019 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .