1

I've got VS Code 1.30.1 (user setup) installed along with: Node: 8.9.3

VS Code Extensions: All the ones availble as part of the Salesforce Extensions Pack

https://marketplace.visualstudio.com/items?itemName=salesforce.salesforcedx-vscode

DX CLI: sfdx-cli/6.44.0-dead729fb5 (windows-x64) node-v8.9.4

on 64-bit Windows.

Whenever, I try to use the SFDX suggestions provided with CTRL+SHIFT+P, I only get errors stating that the underlying commands are not found.

I do have the following entries in my System path:

C:\Program Files (x86)\Common Files\Oracle\Java\javapath
C:\Program Files\nodejs\node_modules\npm\bin
C:\Users\U394282\AppData\Local\Programs\Microsoft VS Code\bin
C:\Users\U394282\AppData\Roaming\npm
C:\Program Files\Salesforce CLI\bin
C:\Program Files\Git\bin
C:\Program Files\Java\jdk1.8.0_181\bin
C:\Program Files\nodejs
C:\Users\myUsername\AppData\Local\sfdx\client\bin

If anyone's seen this, any help with a solution would be appreciated. I don't have the issue on a personal machine, just a corporate one where I don't have admin rights :/

  • Had similar problem, try reinstalling the extension and also you need to reload extension to activate. – Raul Jan 7 at 16:27
  • Tried that multiple times, still didn't help. May have to wait until I can get the whole CLI reinstalled – trebleCode Jan 7 at 16:36
  • Yes I've already tried that – trebleCode Jan 7 at 16:39
  • 1
    Can you share your settings.json file too? it'll be in your .vscode directory. Specifically looking for the value of salesforcedx-vscode-apex.java.home – Derek F Jan 7 at 17:18
  • Sure, I currently have that config value at "salesforcedx-vscode-apex.java.home": "C:\\Program Files\\Java\\jdk1.8.0_192" with a comma after it – trebleCode Jan 7 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.